Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse
 

Gps doesn't work


  • Please log in to reply
83 replies to this topic

#81 jockey79

jockey79
  • Members
  • 2 posts
  • Device Model:
    Wildfire S
  • CM Version:
    7
  • Recovery Image:
    ClockworkMod

Posted 06 January 2012 - 06:16 PM

Just a quick thank you to everyone here for all the help and advice.

I used AndroidFlaser to drop my radio to 19.25, then used ClockWork 2.5.0.7 (as flasher kept returning errors) to put my radio back on 20.10 and everything works great now.

Only had Cyanogen 7.1.0.1-buzz for a couple of days now but I am really enjoying it, more importantly I am enjoying how helpful and friendly I have seen you all to be as I've been reading the forums.

Thanks again

Jockey

#82 divide100

divide100
  • Members
  • 5 posts
  • Device Model:
    LG Optimus 2x
  • CM Version:
    7.1
  • Recovery Image:
    Cyanogen

Posted 07 January 2012 - 05:17 PM

View PostAncestor, on 27 October 2011 - 04:08 PM, said:


su [hit enter]
mount -o remount,rw -t yaffs2 /dev/block/mtdblock3 /system [hit enter]
cp /sdcard/flash_image /system/bin [hit enter]
flash_image recovery /sdcard/recovery.img [hit enter]

When i enter this code into the terminal i get "Error scanning partitions", I checked to make sure all the files are in place, and i found that i dont have an mtdblock3 in my /dev/block/ directory, any ideas?
Thanks,
Divide100

#83 Eslabetas

Eslabetas
  • Members
  • 7 posts
  • Device Model:
    HTC Wildfire
  • CM Version:
    Cyanogenmod 7.0.3 stable
  • Recovery Image:
    ClockworkMod

Posted 01 March 2012 - 01:53 AM

i had this problem too. Downgrading radio or reflashing the current radio didn't work (from recovery and from fastboot). Reflashing all the rom again didn't work (i tried stable and nightly). When open google maps or gps status the gps icon didn't appear in the status bar. But i have solved this problem by flashing the stock rom (i think that any other rom that can get gps to work is valid too), then i turn on gps, making sure that it is working by opening google maps, now i flashed cyanogenmod again (nightly, but stable should work too) and when i open google maps the gps icon is shown!

Tomorrow i will test if it can get signal from satellites, but it looks good.

Sorry for my english.

#84 Andri Agassi

Andri Agassi
  • Members
  • 2 posts
  • Twitter:andriagassi
  • Country:
    id - Indonesia
  • Location:
    Bandung
  • Device Model:
    Samsung Nexus S
  • CM Version:
    ICS 4.0.4
  • Recovery Image:
    TWRP

Posted 09 May 2012 - 07:14 AM

View PostEslabetas, on 01 March 2012 - 01:53 AM, said:

i had this problem too. Downgrading radio or reflashing the current radio didn't work (from recovery and from fastboot). Reflashing all the rom again didn't work (i tried stable and nightly). When open google maps or gps status the gps icon didn't appear in the status bar. But i have solved this problem by flashing the stock rom (i think that any other rom that can get gps to work is valid too), then i turn on gps, making sure that it is working by opening google maps, now i flashed cyanogenmod again (nightly, but stable should work too) and when i open google maps the gps icon is shown!

Tomorrow i will test if it can get signal from satellites, but it looks good.

Sorry for my english.

Me too, I've tried re-flashing every radio version but the GPS still wouldn't work. I'm thinking about doing the same thing as you, flashing the stock ROM. But I'm a little confused about which stock ROM to get. Which one did you get? Can you give me a link to the one you used?