Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse
 

My ways to fix BOOTLOOPING AND MARKET FC


  • Please log in to reply
22 replies to this topic

#1 ShintoKun

ShintoKun
  • Members
  • 42 posts
  • Device Model:
    |2|
  • CM Version:
    CM 5.0.7 DS
  • Recovery Image:
    Cyanogen

Posted 14 July 2010 - 08:27 AM

This is a simple steps to fix it (or so for me) :
1) Go to recovery and Wipe ALL
2) Flash CM6 RC1 AND Google Apps VERSION 3 ONLY!!
3) Reboot out of recovery and let the CM6 load all the way. (Note: it will reboot itself, from some problem)
4) Boot into recovery (Take out battery and put it back in if bootlooping)
5) Wipe data/factory (only)
6) Reboot.
7) Tada! Should not boot-loop any longer.
8) Run FIX PERMISSIONS in ROM MANAGER
9) Reboot.


Sorry if I misspelled some things as I'm writing. This on my mytouch with cm6 :D

Okay, so you guys might have experienced either of these,  because I certainly did. But remember, I might have started out differently.

Problems I had:
When upgrading: bootlooping kept happening after a single boot. Lockscreen was stretched. Marketplace didn't work. Nothing synched. Didn't allow to add google account later. Only corporate. None of the google apps work, did i say that already?

After a fresh entire wipe installation: tapping the android setup didn't do **** until a lag later. Keep tapping that android to get utterly working! :D eventually it'll stop lagging and respond.
Kept bootloping after A few seconds of sucessful load. And had a few Google  app problems.

My info:
During upgrade I had the final 5.0.8.
I'm running it with a mytouch 3g (headjack, 1.2) . I'm using amra recovery 1.7.0, flash it please :D . Another thinng to remember is make sure you have the extra stuff like danger spl ONLY IF YOUR DEVICE REQUIRES IT. Check the official thread for that.

Before I had cm6: I had 5.0.8, ive been using it for a while since it first came out. So as you follow along, keep in mind that I upgraded from a 5.0.8

What I did was:
*1) boot in recovery mode.
2) nandroid backup
3)flashed the cm6 and gapps VERSION 3 (currently the latest)
4) rebooted,  loaded fine. Everything was going okay even the market place. Few things didnt work was that once I rebooted it went into a bootloop.

DO NOT DO THESE STEPS. PLEASE READ IT ANYTHING BEFORE YOU DO ANYTHING!

So I started fresh..

**1) booted into recovery ( I took out the batteries to get out of the dumb bootloop)
2) wiped every single thing on the list.
3) flashed cm6 and gapps version 3.
4) rebooted and when I got into locksxreen or setup it rebooted itself .
5) it did the same effect as 4.

Possible fix?
6) booted into recovery.
7) wiped data (only, usually first one on the list).
8)rebooted.
9) worked without bootlooping!

Other things I did...

10) went into rom manager and used fix permissions.
11)rebooted to recovery.
12) nandroid, so you wont have to do this all again because I don't have an exact starting point that fixed this for me.
13) went to cyanogenmod settings and actives ALL the performmamce tweak for the hell of it. Even 64mb

14) rebooted, sweet and smooth. Let the first time boot tload up before ypi start tapping like **** everywhere

Everything in cm6 works for me. Evven the performance tweaks and it is running smoother than ever!

If you have questions please. Ask, I hopes this helps someone, I know its kinda confusing, but I guess I would suggest starting from step **1.

Man my wrist is aching mytouchhas such a small screen for typing this.


UPDATE: after I did all this so far the only problems left is..
1)click on the weather icon, you'll notice  when you drag accross the timeline it wont change the data above.

More to come later

#2 CountX

CountX
  • Members
  • 37 posts
  • Country:
    us - United States
  • Device Model:
    Dream/Vision
  • CM Version:
    Whatever works
  • Recovery Image:
    ClockworkMod

Posted 14 July 2010 - 10:10 AM

Alright so all I see aside from normal installs of ROM's, especially those that are different builds from currently installed ROM....wipe data after first boot.

Summary;
Install ROM as you would with any new ROM that is a different build.
1)Full wipe
2)Flash ROM
3)Flash GAPPS
4)Boot ROM fully
5)Reboot into recovery
6)Wipe data(technically you can wipe everything)

You're saying those steps fixed your described issues?

#3 ShintoKun

ShintoKun
  • Members
  • 42 posts
  • Device Model:
    |2|
  • CM Version:
    CM 5.0.7 DS
  • Recovery Image:
    Cyanogen

Posted 14 July 2010 - 11:07 AM

Yep, that's the exact steps I took, and I am currently using it with no problems besides the weather bug.

Also,  fix permissions after all those steps you mentioned. You can find that in rom manager that's included in cm6

#4 r1xm

r1xm

    AIRBORNE!

  • Donators
  • 3 posts
  • Twitter:@michaeldunson
  • Country:
    us - United States
  • Location:
    DC
  • Device Model:
    HTC G2
  • CM Version:
    n/a :-(
  • Recovery Image:
    TWRP

Posted 14 July 2010 - 04:37 PM

Worked for me, however Apps2SD was NOT automatic. Installed all apps to the phone memory until it ran out. May be a seperate issue. Thanks for sharing your experience!

#5 invisiblewave

invisiblewave
  • Donators
  • 1140 posts
  • Country:
    us - United States
  • Device Model:
    Sensation
  • CM Version:
    Nightlies usually
  • Recovery Image:
    Stock

Posted 14 July 2010 - 05:02 PM

View PostShintoKun, on 14 July 2010 - 08:27 AM, said:

Sorry if I misspelled some things as I'm writing. This on my mytouch with cm6 :D

Okay, so you guys might have experienced either of these,  because I certainly did. But remember, I might have started out differently.

Problems I had:
When upgrading: bootlooping kept happening after a single boot. Lockscreen was stretched. Marketplace didn't work. Nothing synched. Didn't allow to add google account later. Only corporate. None of the google apps work, did i say that already?

After a fresh entire wipe installation: tapping the android setup didn't do **** until a lag later. Keep tapping that android to get utterly working! :D eventually it'll stop lagging and respond.
Kept bootloping after A few seconds of sucessful load. And had a few Google  app problems.

My info:
During upgrade I had the final 5.0.8.
I'm running it with a mytouch 3g (headjack, 1.2) . I'm using amra recovery 1.7.0, flash it please :D . Another thinng to remember is make sure you have the extra stuff like danger spl ONLY IF YOUR DEVICE REQUIRES IT. Check the official thread for that.

Before I had cm6: I had 5.0.8, ive been using it for a while since it first came out. So as you follow along, keep in mind that I upgraded from a 5.0.8

What I did was:
*1) boot in recovery mode.
2) nandroid backup
3)flashed the cm6 and gapps VERSION 3 (currently the latest)
4) rebooted,  loaded fine. Everything was going okay even the market place. Few things didnt work was that once I rebooted it went into a bootloop.

DO NOT DO THESE STEPS. PLEASE READ IT ANYTHING BEFORE YOU DO ANYTHING!

So I started fresh..

**1) booted into recovery ( I took out the batteries to get out of the dumb bootloop)
2) wiped every single thing on the list.
3) flashed cm6 and gapps version 3.
4) rebooted and when I got into locksxreen or setup it rebooted itself .
5) it did the same effect as 4.

Possible fix?
6) booted into recovery.
7) wiped data (only, usually first one on the list).
8)rebooted.
9) worked without bootlooping!

Other things I did...

10) went into rom manager and used fix permissions.
11)rebooted to recovery.
12) nandroid, so you wont have to do this all again because I don't have an exact starting point that fixed this for me.
13) went to cyanogenmod settings and actives ALL the performmamce tweak for the hell of it. Even 64mb

14) rebooted, sweet and smooth. Let the first time boot tload up before ypi start tapping like **** everywhere

Everything in cm6 works for me. Evven the performance tweaks and it is running smoother than ever!

If you have questions please. Ask, I hopes this helps someone, I know its kinda confusing, but I guess I would suggest starting from step **1.

Man my wrist is aching mytouchhas such a small screen for typing this.


UPDATE: after I did all this so far the only problems left is..
1)click on the weather icon, you'll notice  when you drag accross the timeline it wont change the data above.

More to come later

Just to add a bit more to this subject.  I upgraded from 5.0.8, Google apps didn't get saved/restored, so I flashed the Google package.  Phone stuck at the Android screen, touching it multiple times didn't work.  After several restores/reflashing, I wiped both caches and the Google setup then worked.

Now trying to solve the app problems.  I can't get anything to install, and the sync restore also fails.

#6 ShintoKun

ShintoKun
  • Members
  • 42 posts
  • Device Model:
    |2|
  • CM Version:
    CM 5.0.7 DS
  • Recovery Image:
    Cyanogen

Posted 14 July 2010 - 06:39 PM

Invisiblewave, this is the problem you missed. The apps don't save because the UPGRADE to a news version which. Was provided by cyanogen. Which is verssion 3

And the other thing is, you didn't really described what you did, so I can't follow you. Just use my reccomeended steps,  it helped r1xm

#7 invisiblewave

invisiblewave
  • Donators
  • 1140 posts
  • Country:
    us - United States
  • Device Model:
    Sensation
  • CM Version:
    Nightlies usually
  • Recovery Image:
    Stock

Posted 14 July 2010 - 06:50 PM

View PostShintoKun, on 14 July 2010 - 06:39 PM, said:

Invisiblewave, this is the problem you missed. The apps don't save because the UPGRADE to a news version which. Was provided by cyanogen. Which is verssion 3

And the other thing is, you didn't really described what you did, so I can't follow you. Just use my reccomeended steps,  it helped r1xm

I'm not exactly sure what you mean by this, but I think I'm finally at a point where I can reinstall my apps.  I don't know if I missed something when doing the upgrade, I thought I'd read enough before I started, but this turned out to be the hardest CM upgrade I've done (and I've done a lot).  I had two big issues, first was the Google initialization screen (the Touch The Android bit) which was stuck, I solved this by wiping both caches.  Second was the apps, all my apps disappeared, internal and external, and nothing would install from the market ("install unsuccessful"), nor would they restore from the Google sync.  I tried Stevo's script and that didn't work, so eventually I wiped SD-EXT then installed a single app using Android Commander (ADB Install).  Once that app installed, I could then install from the Market.

Assuming it runs ok, this will be the last experimental CM I install, and I won't be installing any more stable ones until I can do it through CM Updater again.  Much as I enjoy a challenge, especially a software one, I'm fed up with spending half my life screwing around with my phone!

#8 Firerat

Firerat
  • Members
  • 1803 posts
  • Twitter:firer4t
  • Country:
    uk - United Kingdom
  • Device Model:
    Dream aka G1 aka trout
  • CM Version:
    CM6 Magpie Ezt 2708
  • Recovery Image:
    ClockworkMod

Posted 14 July 2010 - 06:51 PM

just how many market fc threads are there?

try

su
rm /mnt/secure/asec/smdl2tmp1.asec

and please read logcat

#9 invisiblewave

invisiblewave
  • Donators
  • 1140 posts
  • Country:
    us - United States
  • Device Model:
    Sensation
  • CM Version:
    Nightlies usually
  • Recovery Image:
    Stock

Posted 14 July 2010 - 09:02 PM

View PostFirerat, on 14 July 2010 - 06:51 PM, said:


and please read logcat

Please see last sentence of previous post!  B)

#10 AndroManiak

AndroManiak
  • Members
  • 3 posts
  • Device Model:
    |2|
  • CM Version:
    CM 5.0.7
  • Recovery Image:
    Amon_RA

Posted 14 July 2010 - 09:09 PM

Is no way to fix the boot loops, I've tried all possibilities.

So I will explain: the problem is relate withe the wifi or APNs

Every time you do this kind of setting, the g1 will start rebooting. Without internet in the phone everything will be ok, no boot loops. Once you enable internet by APNs or Wifi sooner or after first reboot, the phone will enter in boot loops...

Hope to be fixed soon

#11 CountX

CountX
  • Members
  • 37 posts
  • Country:
    us - United States
  • Device Model:
    Dream/Vision
  • CM Version:
    Whatever works
  • Recovery Image:
    ClockworkMod

Posted 14 July 2010 - 09:49 PM

View PostAndroManiak, on 14 July 2010 - 09:09 PM, said:

Is no way to fix the boot loops, I've tried all possibilities.

So I will explain: the problem is relate withe the wifi or APNs

Every time you do this kind of setting, the g1 will start rebooting. Without internet in the phone everything will be ok, no boot loops. Once you enable internet by APNs or Wifi sooner or after first reboot, the phone will enter in boot loops...

Hope to be fixed soon
Using the nightly and I don't see that issue.

#12 AndroManiak

AndroManiak
  • Members
  • 3 posts
  • Device Model:
    |2|
  • CM Version:
    CM 5.0.7
  • Recovery Image:
    Amon_RA

Posted 14 July 2010 - 10:02 PM

View PostCountX, on 14 July 2010 - 09:49 PM, said:

Using the nightly and I don't see that issue.

it is the same, I tried  with cm_dream_sapphire-07142010-171412.... but will enter in boot loop only after you play withe apns or wifi... sometimes after your first reboot

#13 ShintoKun

ShintoKun
  • Members
  • 42 posts
  • Device Model:
    |2|
  • CM Version:
    CM 5.0.7 DS
  • Recovery Image:
    Cyanogen

Posted 14 July 2010 - 10:13 PM

Hey. Not sure why,but its just your device is different from mine, so we don't all have the same issues. Everything works for me

#14 CountX

CountX
  • Members
  • 37 posts
  • Country:
    us - United States
  • Device Model:
    Dream/Vision
  • CM Version:
    Whatever works
  • Recovery Image:
    ClockworkMod

Posted 14 July 2010 - 10:37 PM

I've been using the nightly with 3rd version of mdpi-FRF91-gapps just fine for about a full day now. Much improved experience since the RC1.

#15 ShintoKun

ShintoKun
  • Members
  • 42 posts
  • Device Model:
    |2|
  • CM Version:
    CM 5.0.7 DS
  • Recovery Image:
    Cyanogen

Posted 15 July 2010 - 06:08 AM

View PostCountX, on 14 July 2010 - 10:37 PM, said:

I've been using the nightly with 3rd version of mdpi-FRF91-gapps just fine for about a full day now. Much improved experience since the RC1.

I used RC1 with the 3rd version of the Google Apps fine.
Where do you find these nightly roms?

#16 Firerat

Firerat
  • Members
  • 1803 posts
  • Twitter:firer4t
  • Country:
    uk - United Kingdom
  • Device Model:
    Dream aka G1 aka trout
  • CM Version:
    CM6 Magpie Ezt 2708
  • Recovery Image:
    ClockworkMod

Posted 15 July 2010 - 06:16 AM

View Postinvisiblewave, on 14 July 2010 - 09:02 PM, said:

Please see last sentence of previous post!  B)

sorry, I fail to see your point.

did you have one?

#17 MOF

MOF
  • Members
  • 15 posts
  • Twitter:liveffect
  • Country:
    pk - Pakistan
  • Device Model:
    I9000
  • CM Version:
    Cyanogen Mod 7
  • Recovery Image:
    Cyanogen

Posted 15 July 2010 - 06:30 AM

View PostAndroManiak, on 14 July 2010 - 09:09 PM, said:

Is no way to fix the boot loops, I've tried all possibilities.

So I will explain: the problem is relate withe the wifi or APNs

Every time you do this kind of setting, the g1 will start rebooting. Without internet in the phone everything will be ok, no boot loops. Once you enable internet by APNs or Wifi sooner or after first reboot, the phone will enter in boot loops...

Hope to be fixed soon


yes i agree with you because when ever i enable wifi it i think when start sycning with google there she goes restart and get into looping

#18 Demeryus

Demeryus
  • Members
  • 2 posts
  • Device Model:
    |2|
  • CM Version:
    CM 6.0 RC1 hum bootloop
  • Recovery Image:
    Amon_RA

Posted 15 July 2010 - 10:24 AM

Yup same problem here,
Every time I enable the wifi it goes into bootloop. Going to try another rom until the problem is fixed. A shame, this is a good rom!

Deme

#19 EvilGold

EvilGold
  • Members
  • 12 posts
  • Twitter:evilgold
  • Country:
    us - United States
  • Device Model:
    MT3GS
  • CM Version:
    6
  • Recovery Image:
    ClockworkMod

Posted 18 July 2010 - 08:55 PM

Looks like it worked okay for me, phone isnt rebooting anymore at least.

#20 WoW_horde_chick

WoW_horde_chick
  • Members
  • 1 posts
  • Device Model:
    |2|
  • CM Version:
    CM 6.0.0
  • Recovery Image:
    Amon_RA

Posted 18 July 2010 - 11:15 PM

I don't seem to be having any other problems mentioned here except the market "fc" with the exception of the actual fc error. The market boots up to the normal white screen before it loads then I'm suddenly back at my desktop again. Has anyone found a fix for this?