Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse
 

assert failed: getprop("ro.product.device")


  • Please log in to reply
1 reply to this topic

#1 Bob Jones

Bob Jones
  • Members
  • 45 posts
  • Device Model:
    |1|
  • CM Version:
    RA
  • Recovery Image:
    Cyanogen

Posted 15 November 2011 - 07:15 PM

Friend tried to upgrade his phone the other night and ended up in a weird state. He can boot into recovery but cannot flash either the stable or the nightly. He did manage to get the 7.1 stable installed but due to some weirdness he tried to restore his nandroid. That's where things got messed up. Now whenever a flash is attempted we get the asset failed: getprop error.



"assert failed: getprop("ro.product.device") =="captivate" || getprop("ro.build.product") =="captivate" || getprop("ro.product.board") =="captivate" || getprop("ro.product.device") =="captivatemtd" || getprop("ro.build.product") =="captivatemtd" || getprop("ro.product.board") =="captivatemtd" ||getprop("ro.product.device") =="SGH-I897" || getprop("ro.build.product") =="SGH-I896" || getprop("ro.product.board") =="SGH-I896" || getprop("ro.product.device") =="SGH-I897" || getprop("ro.build.product") =="SGH-I897" || getprop("ro.product.board") =="SGH-I897"
E: Error in /sdcard/update-cm-7.1.0-Captivate-signed.zip
(Status 7)

all the build I am getting assert failed error.


I tried changing in build.prop ,from "captivatemtd" to "captivate" as recommended somewhere.

Tried a resolution from another user
build.prop was absent in my device as it was first flash/had wiped cahe and sdcard earlier.
So removed the assert cmds from META-INF\com\google\android\update-script from build zip file.It worked like charm.

No difference

I can't get the phone to connect in windows to do either of those revert to stock methods.
Is there a way to get around this error or is there a way to get back to stock using linux.

Any ideas?

We have no problems getting into download mode or recovery 2.5.1.0 SpeedMod ULFK

#2 Bob Jones

Bob Jones
  • Members
  • 45 posts
  • Device Model:
    |1|
  • CM Version:
    RA
  • Recovery Image:
    Cyanogen

Posted 16 November 2011 - 12:06 PM

Found the answer in this thread.
Flashed back to stock and then upgraded

http://forum.xda-dev...d.php?t=1191094