Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse
 

Status 7 error when installing rom


This topic has been archived. This means that you cannot reply to this topic.
1 reply to this topic

#1 pixilinares

pixilinares
  • Members
  • 1 posts

Posted 10 April 2012 - 03:52 PM

Hi Guys,

this is the first time im instaling CM9 on my xperia arc Lt15i doing the folowing:

- rooted device
- opened blocked bootloader (now using clockworkmod 5)

I downloaded the update-cm-9-20120404-NIGHTLY-anzu-signed.zip and also update-cm-7.2.0-RC1-anzu-signed.zip when i started the phone and tried to flash after doing wipe data/factory reset i got the following error:

getprop("ro.product.device") == "LT15a" || getprop("ro.build.product") == "LT15a" ||        getprop("ro.product.device") == "anzu" || getprop("ro.build.product") == "anzu"
E:Error in /sdcard/update-cm-9-20120404-NIGHTLY-anzu-signed.zip
(Status 7)
Installation aborted.
result was NULL, message is: assert failed: install_zip("/sdcard/update-cm-9-20120404-NIGHTLY-anzu-signed.zip")

I spent hours reading and cant find what to do in order to install the rom, help will be appreciated!

#2 ciwrl

ciwrl

    Whose bright idea was it to put me in charge?

  • Administrators
  • 1621 posts

Posted 10 April 2012 - 03:58 PM

The Arc variant we target is the LT15a (you have a LT15i). I believe the difference is a slight variance in hardware. That said, the following comes with a big do this at your own risk

You can open the zip file, open the updater-script file (with something like gedit or notepadd++) and remove the getprop lines. Rezip the file and you will now be able to flash the zip.