Jump to content

Welcome to CyanogenMod

Welcome to our forum. Like most online communities you must register to post, but don't worry this is a simple free process that requires minimal information for you to signup. Be a part of the CyanogenMod Forum by signing in or creating an account. You can even sign in with your Facebook or Twitter account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get automatic updates
  • Get your own profile and make new friends
  • Download files attached to the forum.
  • Customize your experience here
  • Share your CyanogenMod experience!
Guest Message by DevFuse
 

BT audio issue


  • Please log in to reply
8 replies to this topic

#1 flipside3547

flipside3547
  • Members
  • 21 posts
  • Twitter:@flip3547
  • Country:
    us - United States
  • Location:
    Clearwater, Fl
  • Device Model:
    HTC Sensation
  • CM Version:
    CM7 AlphaKang 7
  • Recovery Image:
    ClockworkMod

Posted 11 September 2010 - 03:59 AM

Sorry to start this topic new, but couldnt find it except in the nexus forum. Anyways, I just got a BT headset for bday, I start to play music to it from my sdcard and after a minute or two, it starts to cut in and out alot. So much I just cant use it to listen to music. I read I could turn off phone audio, tried that, didnt work. And I'd love to use it for both calls and audio. Has anyone had this problem and if so, have you gotten a fix. Thanks in advance for anyone who can help on this issue. Sorry for the book. Also, I have to say, I cant really find any other problem with this rom. A little lag here and there but this and that is it. Love what these people do. Great, Great work!!!!!

Edited by flipside3547, 11 September 2010 - 04:03 AM.


#2 g00gler

g00gler
  • Members
  • 12 posts
  • Device Model:
    Rogers HTC Magic
  • CM Version:
    Stock
  • Recovery Image:
    TWRP

Posted 11 September 2010 - 05:46 AM

I just got a new Bluetooth enabled stereo and noticed that it would cut in and out every minute or so.
When I turned off my wi-fi, that issue stopped. My theory, is that since Bluetooth and wi-fi both use the same frequency, and probably even the same chip, there is some interference when the wi-fi is scanning for networks. It seems to happen on all ROMS, from stock to CM6, so I am convinced it is hardware.

Hope that helps

#3 flipside3547

flipside3547
  • Members
  • 21 posts
  • Twitter:@flip3547
  • Country:
    us - United States
  • Location:
    Clearwater, Fl
  • Device Model:
    HTC Sensation
  • CM Version:
    CM7 AlphaKang 7
  • Recovery Image:
    ClockworkMod

Posted 11 September 2010 - 04:49 PM

View Postg00gler, on 11 September 2010 - 05:46 AM, said:

I just got a new Bluetooth enabled stereo and noticed that it would cut in and out every minute or so.
When I turned off my wi-fi, that issue stopped. My theory, is that since Bluetooth and wi-fi both use the same frequency, and probably even the same chip, there is some interference when the wi-fi is scanning for networks. It seems to happen on all ROMS, from stock to CM6, so I am convinced it is hardware.

Hope that helps
Well I've shut off the wifi to no avail, thanks for the suggestion.

#4 invisiblewave

invisiblewave
  • Donators
  • 1140 posts
  • Country:
    us - United States
  • Device Model:
    Sensation
  • CM Version:
    Nightlies usually
  • Recovery Image:
    Stock

Posted 11 September 2010 - 04:52 PM

View Postg00gler, on 11 September 2010 - 05:46 AM, said:

I just got a new Bluetooth enabled stereo and noticed that it would cut in and out every minute or so.
When I turned off my wi-fi, that issue stopped. My theory, is that since Bluetooth and wi-fi both use the same frequency, and probably even the same chip, there is some interference when the wi-fi is scanning for networks. It seems to happen on all ROMS, from stock to CM6, so I am convinced it is hardware.

Hope that helps

WiFi and Bluetooth share neither the same frequency nor the same chip.

View Postflipside3547, on 11 September 2010 - 04:49 PM, said:

Well I've shut off the wifi to no avail, thanks for the suggestion.

Have you tried a different headset?  I use an Accoustic Research bluetooth bridge for streaming audio without any problems.  The only time I get any cutoff is when streaming audio over the data connection due to T-Mobile's crappy 3G coverage, I get better continuity on 2G.

#5 flipside3547

flipside3547
  • Members
  • 21 posts
  • Twitter:@flip3547
  • Country:
    us - United States
  • Location:
    Clearwater, Fl
  • Device Model:
    HTC Sensation
  • CM Version:
    CM7 AlphaKang 7
  • Recovery Image:
    ClockworkMod

Posted 12 September 2010 - 12:46 AM

[/quote]
Have you tried a different headset?  I use an Accoustic Research bluetooth bridge for streaming audio without any problems.  The only time I get any cutoff is when streaming audio over the data connection due to T-Mobile's crappy 3G coverage, I get better continuity on 2G.
[/quote]

I've tried 2 other headsets but they both do not support a2dp. Only for phone calls. I haven't had them in use long enough to notice any stuttering during a phone call. I will try the 2G only and see how that goes. Thanks for the tip.
Anyone else with ideas keep them coming, I can't wait to find a solution. I will try anything.

Edited by flipside3547, 12 September 2010 - 12:46 AM.


#6 powerhousepro

powerhousepro
  • Members
  • 1 posts
  • Device Model:
    HTC Magic Mytouch 3.5mm
  • CM Version:
    5.0.8
  • Recovery Image:
    Cyanogen

Posted 12 September 2010 - 04:04 AM

I have the magic (3.5mm version).  I rooted and went to Cyanogen 6.  Ever since then (via bluetooth) :  Pandora Cuts out, Slacker Cuts out, Beyond Pod cuts out and the default music player cuts out but not as much.  This is using 4 different Stereo Bluetooth Devices.  All these devices worked fine with the stock 1.6 on my magic.  This occurs if I am playing an MP3 on my SD card or if I am streaming from TMO or WIFI.  Also, youtube streamed just fine via wifi now it cuts out using the built in speaker and bluetooth (on all 4 of my bluetooth devices).  I played a youtube vid from my SD card and It cuts out also. That rules out network congestion.  It is my opinion that the magic just isnt powerful enough for Android 2.2.  and if thats the case, the G1 definately isnt powerful enough to run it.  i actually tried it on my G1 and it is very, very sluggish.  As to the mytouch,  The Caynogen mod rocks with everything except all the media cutting out.

Edited by powerhousepro, 12 September 2010 - 04:13 AM.


#7 invisiblewave

invisiblewave
  • Donators
  • 1140 posts
  • Country:
    us - United States
  • Device Model:
    Sensation
  • CM Version:
    Nightlies usually
  • Recovery Image:
    Stock

Posted 12 September 2010 - 02:46 PM

View Postpowerhousepro, on 12 September 2010 - 04:04 AM, said:

I have the magic (3.5mm version).  I rooted and went to Cyanogen 6.  Ever since then (via bluetooth) :  Pandora Cuts out, Slacker Cuts out, Beyond Pod cuts out and the default music player cuts out but not as much.  This is using 4 different Stereo Bluetooth Devices.  All these devices worked fine with the stock 1.6 on my magic.  This occurs if I am playing an MP3 on my SD card or if I am streaming from TMO or WIFI.  Also, youtube streamed just fine via wifi now it cuts out using the built in speaker and bluetooth (on all 4 of my bluetooth devices).  I played a youtube vid from my SD card and It cuts out also. That rules out network congestion.  It is my opinion that the magic just isnt powerful enough for Android 2.2.  and if thats the case, the G1 definately isnt powerful enough to run it.  i actually tried it on my G1 and it is very, very sluggish.  As to the mytouch,  The Caynogen mod rocks with everything except all the media cutting out.

Do you have Swap enabled?

#8 flipside3547

flipside3547
  • Members
  • 21 posts
  • Twitter:@flip3547
  • Country:
    us - United States
  • Location:
    Clearwater, Fl
  • Device Model:
    HTC Sensation
  • CM Version:
    CM7 AlphaKang 7
  • Recovery Image:
    ClockworkMod

Posted 12 September 2010 - 04:47 PM

View Postinvisiblewave, on 12 September 2010 - 02:46 PM, said:

Do you have Swap enabled?
I do. 32MB swap partition, swappiness 10

#9 trollkarlen

trollkarlen
  • Members
  • 1 posts
  • Device Model:
    |2|
  • CM Version:
    4.2.2
  • Recovery Image:
    Cyanogen

Posted 14 September 2010 - 07:00 PM

View Postflipside3547, on 12 September 2010 - 04:47 PM, said:

I do. 32MB swap partition, swappiness 10

I have issues with the sound and BT headset:
1. The sound cuts out in certain intercalls the intervall is a litte bit diffrent from time to time.
2. The playing stops and dont resumes.

/T